WordPressのFlashアップローダーで「IOエラー」。

WordPress2.9.2で、画像をFlashアップローダーの方であげようとしたらこんなエラーが出ました。

IOエラー

WordPressのフォーラムなどを調べてみると、「IE8だとこのエラーになる」というような声もあるんですが、僕が使っているのはFireFox3.5です。

他にいくつかのブラウザで試してみたけどどうやらダメっぽい。

ここでWordPressが使っているのは、SWDUploadというやつで、この開発元のサンプルが動作するとしたら、ブラウザの問題じゃないということになります。

SWFUpload Demos – Simple Demo

他に気になることと言えば、SSLがオレオレ証明書(信頼できない証明書)なことくらいでしょうか。

どうやらこっちが原因っぽいです。

AdminSSLを停止して、HTTPで試してみたらうまくいきました。

結論。

SSLの証明書がちゃんとしていないと、Flasアップローダーが使えないことがある。

About: adminuser


1 thought on “WordPressのFlashアップローダーで「IOエラー」。”

Leave a Reply

Your email address will not be published. Required fields are marked *